# I have an error with the configuration file

**URL:** https://forum.suricata.io/t/i-have-an-error-with-the-configuration-file/3502
**Category:** Help
**Tags:** configuration, suricata
**Created:** [May 15, 2023, 10:24am UTC](https://forum.suricata.io/t/i-have-an-error-with-the-configuration-file/3502 "2023-05-15T10:24:15Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Yousef\_Helmy](https://yyz2.discourse-cdn.com/flex030/user_avatar/forum.suricata.io/yousef_helmy/32/2060_2.png) [@Yousef\_Helmy](https://forum.suricata.io/u/Yousef_Helmy)
#### Post date: [May 15, 2023, 10:24am UTC](https://forum.suricata.io/t/i-have-an-error-with-the-configuration-file/3502/1 "2023-05-15T10:24:15Z")

</div>

- [ERRCODE: SC\_ERR\_CONF\_YAML\_ERROR(242)] - Failed to parse configuration file at line 60: found character that cannot start any token  
I attached a copy of the configuration  
[suricataCon.yaml](https://forum.suricata.io/uploads/short-url/g7G5hoemvZJH6C0Iz9TH40S6HVU.yaml) (73.1 KB)

---

<div class="post-metadata">

### Author: ![Jeff\_Lucovsky](https://yyz2.discourse-cdn.com/flex030/user_avatar/forum.suricata.io/jeff_lucovsky/32/11_2.png) [@Jeff\_Lucovsky](https://forum.suricata.io/u/Jeff_Lucovsky)
#### Post date: [May 16, 2023, 1:26pm UTC](https://forum.suricata.io/t/i-have-an-error-with-the-configuration-file/3502/2 "2023-05-16T13:26:04Z")

</div>

The Suricata configuration is prepared during the `configure` step. During this step, templated fields from the Suricata configuration template file (`suricata.yaml.in`) are substituted with values according to the configuration settings supplied when running `configure`.

The Suricata configuration file you posted contains templated fields that haven’t been substituted. My suggestion is to run `configure [other-configure-pptions as needed`] and then retry using Suricata.

`configure` will create ` suricata.yaml` file with the proper values for your deployment in place of the templated fields. Templated fields are surrounded with the `@` value, e.g., `@e_conflogdir@`.
