Contributing to Suricata-verify

Hello! I’m Tharushi, former Outreachy intern. I would like to continue contributing to SV and I was going through the tickets I was assigned to see if there’s any work left to be done.

I came across a SV feature request: To print a summary of failed tests at last.

In order to check whether it was already implemented, I got a pull from master and ran the SV tests from my Suricata source directory using ../path/to/suricata-verify/run.py .

It’s running for about half an hour now and it doesn’t seem to stop. Is this normal? IIRC, it didn’t take so long. I’m wondering whether my SV tests are running in an endless loop. I’m seeing the same tests being run again, and most of the time it appears as if the terminal is stuck after this geoip test.

Please let me know if I’m doing anything incorrectly here.

1 Like

Hey Tharushi!

Good to see you here :slight_smile:
I tried running s-v here and while I did notice more usage of memory and CPU, it went quite fast. Looking at the output you’ve shared, I see “requires at least version 7”. Is it possible that you checked out an older master branch? Afaik, the developer branch is at 7, currently…

Regarding the need for this feature, it is better to wait for mr @ish or maybe @sbhardwaj to answer, I do know we have a --quiet command line option, now, that will only print a summary…
image

But not sure if the issue you’re talking about has more than this to be done…

Glad to see you back!

Hi Tharushi!

Yes, as Juliana said, please check you are running master on both. Note that I just pushed a fix to suricata-verify to fix its default verbosity level which was made quieter by the side affect of a recent commit.

Unfortunately though, I’m not sure how useful that feature ticket is with our new quiet mode. It essentially gives you the same result as whats suggested in that ticket with less complexity. I’ll give it another thought, but will likely close that ticket out. Sorry about that.