How can i setup the secret-code correctly?

Hello, we tried to setup the rule-source with the command like "suricata-update enable-source et/pro secret-code=xxxxxxxxxxxxxxxx“, but why did we receive an error message like:

KeyError: ‘secret-code’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/local/bin/suricata-update”, line 33, in
File “/usr/local/lib/python3.8/dist-packages/suricata/update/”, line 1305, in main
File “/usr/local/lib/python3.8/dist-packages/suricata/update/”, line 1146, in _main
files = load_sources(suricata_version)
File “/usr/local/lib/python3.8/dist-packages/suricata/update/”, line 898, in load_sources
url = (index.resolve_url(name, params), http_header,
File “/usr/local/lib/python3.8/dist-packages/suricata/update/”, line 132, in resolve_url
raise Exception(“Missing URL parameter: %s” % (str(err.args[0])))
Exception: Missing URL parameter: secret-code

What version of suricata-update are you running?
I couldn’t reproduce it

thank you, it’s 1.2.2

How did you install it?
What is the system you use and the shell?
Testing it with 1.2.2 did work as well, so must be something specific to your installation/setup

OS is ubuntu 18.01, after i have suricata installed i didn’t install suricata-update additionally. Should i re-install it with following the instructions from Git-hub?

How did you install it exactly in Ubuntu?
And yes you could try to directly use the release from github.

Also, if you just run suricata-update enable-source et/pro you should be prompted for the secret code.

However, I just tested both variants of adding et/pro with 1.2.2 and it works, at least on my system.

Are you getting this error during the enable-source command, or a subsequent call to suricata-update to update the rules?