Scirius / Suricata GUI problem

Hi everyone, I have a problem configuring Scirius ( GUI ) with Suricata. launching the commands to start both, from termimal everything seems to work correctly and also the logs are written correctly. it seems that scirius is unable to intercept events.

Suricata run command

sudo suricata -c /etc/suricata/suricata.yaml -i eth0

Scirius run command

python runserver < ip:port >

This is the configuration of suricata on scirius

The rules have been enabled in the graphical interface and during the suricata configuration, but scirius does not seem to detect any events:



also scirius does not load the menu on the right well:


The version of Suricata is 5.0.3, Scirius is 3.4.0 and the version of ES is 7.9.2

Could it be a version incompatibility issue of Suricata or Scirius? Or a configuration problem?

Could you give me some solution on how to solve the problem?

Thanks in advance

What is the name of the Elastcisearch index you are using to store alerts ? If not ‘logstash-*’ something, you may need to set up ELASTICSEARCH_LOGSTASH_ALERT_INDEX in to get data seen in Scirius.

On the icon side, you may need to run ‘python collectstatic’.

This is the configuration file `` ‘’, it seems configured correctly.

I also tried to edit the ``’’ file but nothing happens

Also, the command to fix the icons did not solve the other problem

Do you see data in Kibana ?

With regards to the icons can you click right and open the image in a new tab, then paste the URL here so I can see what is happening ?

This is what happens when you do what you asked for, as far as icons are concerned.

( link http://ip:8000/static/rules/Stamus_SPM_icon.png )

Kibana has already been installed but I can’t connect to the web interface. I also installed apache2 to start kibana but it still doesn’t work