Suricata 7.0.4 compiles with gcc debugging enabled by default?

snippet from “suricata --build-info” below, notice the -g -O2

Host: x86_64-unknown-freebsd14.0
Compiler: gcc (exec name) / c++ (real)
GCC Protect enabled: no
GCC march native enabled: yes
GCC Profile enabled: no
Position Independent Executable enabled: no
CFLAGS -g -O2 -DOS_FREEBSD -std=c11 -march=native -I${srcdir}/…/rust/gen -I${srcdir}/…/rust/dist

  1. Is suricata supposed to be compiled with gcc debuging symbols by default?
  2. How do one go about to disable these? (ideally without having to edit files)

Hello, has anyone experienced the problem that the Suricata 7.0.4_1 service does not initialize. I’m using pass

I don’t think the Suricata build scripts set these by default, or at all. How are you building Suricata?

Please open your own topic for this unrelated question.

./configure --enable-ipfw --enable-luajit --with-libluajit-includes=/usr/local/include/luajit-2.1 --with-libluajit-libraries=/usr/local/lib