Suricata - Installation Issues

When I try to run the "CFLAGS="-O0 -ggdb -fno-omit-frame-pointer" ./configure --disable-shared --enable-debug --enable-unittests" command I get the error “pcre2 not found” although it is installed.
DIgging deeper I have found that it is installed but the path is not getting recognized. Instead of getting installed in the bin folder, it is getting installed to the opt/homebrew/Cellar in Mac and the path is not reflecting for this.
Any insights here would be helpful. Thanks

Looks like some options weren’t added when we moved from pcre1 to pcre2. I’ve opened a ticket:

1 Like

So I got it working(I think) with a weird workaround. I uninstalled it using homebrew and then downloaded the tar from the library website and then followed the instructions to install it in the readme.
After this, I did not get the same error and could go through the remaining installation process.

My question here is: Is it ok if I am building on Mac, and would I be able to contribute easily or is it going to be an issue. Dont want to go through the installation process again. :face_with_peeking_eye:

1 Like

[Mac users] For anyone here who comes looking for answers I am documenting the steps for installation below along with some references that I found along the way.

Mac Installations Steps

  • Read Getting Started Contributing to Suricata - Suricata

  • Follow Installation Guide

  • I translated the steps to Mac by downloading the packages mentioned one by one.

  • You can try running via homebrew as well but I later had issues with the brew installation due to installation directory issues.

  • To directly download the package:

    • You can google the package name e.g pcre2.
    • Install the tar file.
    • Open in the directory and simply install it by commands(in terminal) > ./configure > make > sudo make install
  • Clone the suricata repository into a new directory and follow remaining steps after that on installation page.

  • Instead of ./configure run "CFLAGS="-O0 -ggdb -fno-omit-frame-pointer" ./configure --disable-shared --enable-debug --enable-unittests

Feel free to reach out if you have any questions (I am still learning though).

Other references : Another thread on issues/installation discussions

2 Likes

Nice! Thank you for thread. Unfortunately am running windows, I didnt run to such an issue.

1 Like

Glad that know that you’ve found a way!

To answer your question: we have some community members who use Mac. Even one of our past interns did. So, you certainly can code and and contribute using a Mac. Now and then you may find bumps on the road, but there are some folks who may offer hints. (and we all face bumps, eventually! :stuck_out_tongue: )

1 Like