Unable to locate suricata.yaml file on mac m2 pro

Please include the following information with your help request:

  • Suricata version - 7.0.2
  • Operating system and/or Linux distribution- mac os Venture 13.4 - mac m2 pro
  • How you installed Suricata (from source, packages, something else)- installed suricata from brew
    I am getting the following error:
    Error: conf-yaml-loader: failed to open file: suricata.yaml: No such file or directory
    How to find suricata.yaml file on mac m2 pro?

It seems like you don’t have suricata.yaml configuration file in the default location.
Run Suricata with -c <PATH> argument to provide path to your custom suricata.yaml file.

i have installed suricata with brew . the command you suggested did not work.

You were supposed to provided path to your suricata.yaml file after the -c argument`.

How do you exactly run Suricata?

Suricata.yaml is by default located in /etc/suricata folder, it may be in a folder like /usr/local/etc/suricata/

thank you, It worked. I am new to suricata , i’m figuring out slowly. I am getting the following error when I run suricatasc

Unable to connect to socket /opt/homebrew/var/run/suricata/suricata-command.socket: L178: [Errno 61] Connection refused

Please post your suricata.yaml and the command on how you run Suricata including the command line arguments.

Also for beginners I would recommend to read our docs: http://docs.suricata.io/